Common Installation Issues
GlobalSearch is a complex program, tying multiple external systems together and relying heavily on Microsoft infrastructure. We run two distinct database systems, integrate with Active Directory, and a host of 3rd party software and hardware.
This guide contains fixes for common installation issues. Please feel free to consult the Installation Guide for the proper process and prerequisites for your install.
SQL Server Install Failure
When installing GlobalSearch 4.5.2 or older, or installing GlobalCapture 2.1.2 or older, the MS SQL Server installer may fail and you may receive an error like the one shown below. This can also occur when SQL Server and Active Directory exist on the same machine. There are major issues that can arise as a result of installing SQL Server on a domain controller, please review the link from Microsoft that describes these issues. In the event that this cannot be avoided, follow the steps below.
Security Considerations - SQL Server
Solution
During the install, at the Server Configuration, change the Account Name for the Database Engine to NETWORK SERVICE. If NETWORK SERVICE does not work, use NT AUTHORITY\SYSTEM. This will use a preset user to build the database properly.
IIS Components Are Missing In The Registry
If you receive an error stating that IIS Components aren’t present in the registry, your installer can run a quick regedit to add the registry keys.
Open Windows registry editor and navigate to the following key:
regedit.exe in “run” or in Search Program Files then drill down to the registry value below:
HKLM\Software\Wow6432Node\Microsoft\InetStp\Components
*In order to make any changes to the key you must take ownership of the key and then grant yourself permissions to modify the key.*
Create a new DWORD called: WindowsAuthentication. Give it a value of 1
Create another DWORD called: BasicAuthentication. Give it a value of 1
Create another DWORD called: ASPNET. Give it a value of 1.
After adding these three values, you should be able to proceed with the installation.
Installing GlobalCapture on an RDS Environment
RDS servers are similar to Terminal/Application servers, but there are some mild differences in how they handle Windows Installers. Windows RDS 2008 and 2012 have a specific aspect that will need to be enabled to allow for the chained installer that is now part of the GlobalCapture Install process.
Common Symptom
When the GlobalCapture Engine Installer kicks off as part of the main Application installer, it will stall out or hang for over 20 minutes until it times out.
Common Cause
1. RDS server was not put into “Install Mode”. RDS servers have to be set to allow installs either from Control Panel or a CMD prompt.
2. The Group Policy for “Turn off Windows Installer RDS Compatibility” is either not set or Disabled. This policy when NOT enabled (see screenshot below) will prevent multiple Windows installers from running.
Proper Install Process
Set the server to install mode. I found the easiest way is to use CMD prompt as admin and type:
Change User /Install
Remember to set this back to regular use once all installs are done. This can be done by typing:
Change User /Execute
Enable the Group Policy mentioned above.
Log on to the system with a User that has Administrative Privileges
Open the Windows Control Panel
Perform a search for Group Policy
The search results should display a link to the “Local Group Policy Editor”
Once inside the editor, go to:
Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Application Compatibility
In the right pane, right-click on ‘Turn off Windows Installer RDS Compatibility” and select Edit from the drop-down menu
Select the Radio Button labeled Enable
Click OK
Confirm that there are no leftover setup.exe or Windows Installer instances running using Task Manager.
Run our application installer as you normally would by right-clicking and “Run as administrator”.
Chained installer for GlobalCapture should run as expected.
As mentioned above, make sure to set the server back to full function mode via the CMD prompt.
Help! My Services Didn’t Install
No problem. We have a set of CMD scripts that you can run piece by piece or as a .bat file to write all your services. Please see this Knowledge Base article HERE
Creation of a Link Item Database Fails During Installation
On installation, you are prompted with this error before the installer fails out
Error Message
{"Message":"An error occurred while trying to create a new database: Could not load file or assembly 'Microsoft.SqlServer.BatchParser, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified."}
Solution
This is likely a missing file from the SQL Server that can be installed via a SQL Server feature pack. Normally this is packaged with the install, but you can download and run the feature packs from Microsoft's website to have the component reinstalled.
Download and install the Feature Pack for your version of SQL Server below. A restart may be required.
SQL Server has a different Server Collation
Your previously installed instance of SQL may have a different collation than the installer is trying to write. The Green box on the left is the default US collation.
Solution: Install a new SQL named instance with the default US collation - SQL_Latin1_General_CP1_CI_AS.
See Microsoft article for more details.
SQL Server collation
Install error
Error 27506 Error executing SQL script SSMaster.sql. Line 251 Invalid column name 'iid'. (207)
Inside of Global Search error if the install goes through.
These error messages indicate that the install is unable to access or open one or more SQL databases. This can be caused by insufficient privileges, file system compression, another program (e.g., antivirus), or missing database files.